Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
Next revision
Previous revision
requirements [2013/02/20 13:57]
steve
requirements [2019/08/11 17:56] (current)
ids-shuhao
Line 1: Line 1:
 ===== Requirements ===== ===== Requirements =====
-Below are the minimum and necessary requirements for the applications and tools to be used for the Mobilize project in 2013.  Please refer to these to ensure that your lab and/or devices are able to run the necessary tools.  ​If you have questions but they don't seem to be covered here, please [[:​contact|contact us]].+Below are the minimum and necessary requirements for the applications and tools to be used to support implementation of the IDS curriculum.  Please refer to these to ensure that your labs and/or devices are able to run the necessary tools.  ​
  
-==== Mobilize ​Web Browser Requirements ​==== +If you have questions but they don't seem to be covered here, please [[:​contact|contact us]]. 
-The Mobilize Web Frontend is a customization of the ohmage ​web frontend. It supports the most common ​browsers.+ 
 +There are two main software tools used in IDS: 
 +  - IDS software suite for data collection and visualization. 
 +  - RStudio for hands-on data analysis.  
 + 
 +==== 1 IDS software suite ==== 
 +=== 1.1 IDS Web Browser Requirements === 
 +The IDS web tools are used for data collection and visualization. It supports the following modern ​browsers.
   * Chrome   * Chrome
   * Firefox   * Firefox
-  * Safari +  * Safari ​ 
-  * Internet Explorer, **only*when using the [[http://​www.google.com/​chromeframe|Chrome Frame plugin]]+Not recommended 
 +  * Internet Explorer 
 +  ​Microsoft Edge
  
-==== Mobilize ​Mobile App Requirements ​==== +=== 1.2 IDS UCLA Mobile App Requirements === 
-=== Mobilize ​Android App Requirements === +The IDS UCLA mobile apps are mainly used for data collection. The apps are available on the Android and iOS devices: 
-The Mobilize ​Android app is a customization of the ohmage native android project. It supports many Android devices ​and device types. +== Android App == 
-== Android version minimum requirements == +The IDS UCLA Android app supports many Android devices ​with the Android 5.1+ operating system.  
-  * Android 2.and newer is supported. +  * To ensure compatibility,​ visit the [[https://​play.google.com/​store/​apps/​details?​id=edu.ucla.oit.idsucla|Google Play Store]] page for the IDS UCLA app and try to install (you'​ll be notified if your device ​isn't supported)!
-    * Visit your settings menu, scroll to "About phone" or "​About ​device" to determine your model's current Android version.+
  
-=== Mobilize MWF iOS App Requirements === +== Apple iOS App == 
-The Mobilize MWF iOS App is a customization of the ohmage MWF project. ​ It supports ​many of the different ​Apple iOS models. +The IDS UCLA iOS app supports the following ​Apple iOS devices with the iOS 9.0+ operating system.  
-== Minimum model requirements == +  * iPhone  
-  * iPhone ​(3gs, 4, 4s, 5 and newer are supported) +  * iPod touch  
-  * iPod touch (3rd, 4th, 5th genrations and newer) +  * iPad 
-  ​* **possibly not available from the iOS store** iPad (iPad 2, 3rd generation, 4th generation and newer) +  * To ensure compatibility,​ visit the [[https://​apps.apple.com/​us/​app/​ids-ucla/​id1422869521|Apple App Store]] page for the IDS UCLA app and try to install (you'​ll be notified if your device isn't supported)!
-  * **possibly not available from the iOS store** iPad mini+
  
-==== RStudio Web Browser Requirements ==== +==== RStudio Web Browser Requirements ==== 
-RStudio is an external, open-source project. ​ While they have very liberal browser requirements,​ below is a list of those they recommend on [[http://​support.rstudio.org/​help/​kb/​advanced/​optimizing-your-browser-for-rstudio|this page]] +RStudio is an external, open-source project. ​It supports the following modern browsers
- +  * Chrome 
-== Minimum version requirements == +  * Firefox 
-  * Firefox ​3.5 +  * Safari ​ 
-  * Safari ​4.0 +Not recommended 
-  * Google Chrome 5.0 +  * Internet Explorer 
-  * Internet Explorer (when using the [[http://​www.google.com/​chromeframe|Chrome Frame plugin]])+  * Microsoft Edge
Print/export