Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
Next revision
Previous revision
requirements [2013/03/04 10:57]
steve
requirements [2019/08/11 17:56] (current)
ids-shuhao
Line 1: Line 1:
 ===== Requirements ===== ===== Requirements =====
-Below are the minimum and necessary requirements for the applications and tools to be used for the Mobilize project in 2013.  Please refer to these to ensure that your lab and/or devices are able to run the necessary tools.  ​If you have questions but they don't seem to be covered here, please [[:​contact|contact us]].+Below are the minimum and necessary requirements for the applications and tools to be used to support implementation of the IDS curriculum.  Please refer to these to ensure that your labs and/or devices are able to run the necessary tools.  ​
  
-There are two main software tools used in the Mobilize projects+If you have questions but they don't seem to be covered here, please [[:​contact|contact us]]. 
-  - Mobilize ​software suite for data collection and visualization.+ 
 +There are two main software tools used in IDS
 +  - IDS software suite for data collection and visualization.
   - RStudio for hands-on data analysis. ​   - RStudio for hands-on data analysis. ​
  
-==== 1 Mobilize ​software suite ==== +==== 1 IDS software suite ==== 
-=== 1.1 Mobilize ​Web Browser Requirements === +=== 1.1 IDS Web Browser Requirements === 
-The Mobilize Web Frontend is a customization of the ohmage ​web frontend. It supports the following ​common ​browsers.+The IDS web tools are used for data collection and visualization. It supports the following ​modern ​browsers.
   * Chrome   * Chrome
   * Firefox   * Firefox
-  * Safari +  * Safari ​ 
-  * Internet Explorer, **only*when using the [[http://​www.google.com/​chromeframe|Chrome Frame plugin]]+Not recommended 
 +  * Internet Explorer 
 +  ​Microsoft Edge
  
-=== 1.2 Mobilize ​Mobile App Requirements === +=== 1.2 IDS UCLA Mobile App Requirements === 
-The Mobilize ​mobile apps are mainly used for data collection. The apps are available on the Android and IOS smartphones:+The IDS UCLA mobile apps are mainly used for data collection. The apps are available on the Android and iOS devices:
 == Android App == == Android App ==
-The Mobilize ​Android ​phone app supports many Android devices ​and device types. The app requires ​the following ​Android ​version: +The IDS UCLA Android app supports many Android devices ​with the Android ​5.1+ operating system.  
-  * Android 2.2 and newer. Visit your settings menu, scroll to "About phone" or "About device"​ to determine your model'​s current Android version+  * To ensure compatibility,​ visit the [[https://play.google.com/store/​apps/​details?​id=edu.ucla.oit.idsucla|Google Play Store]] page for the IDS UCLA app and try to install (you'​ll be notified if your device ​isn't supported)!
-  * ECS Students/​Teachers looking to ease the discover of supported Android devices can visit **[[http://is.gd/mobilize2013|this page]]** from the mobile ​device ​to have support automatically detected. ​+
  
 == Apple iOS App == == Apple iOS App ==
-The Mobilize IOS app supports the following Apple iOS devices ​and models: +The IDS UCLA iOS app supports the following Apple iOS devices ​with the iOS 9.0+ operating system. ​ 
-  * iPhone ​(3gs, 4, 4s, 5 and newer are supported) +  * iPhone  
-  * iPod touch (3rd, 4th, 5th genrations and newer) +  * iPod touch  
-  ​* **possibly not available from the iOS store** iPad (iPad 2, 3rd generation, 4th generation and newer) +  * iPad 
-  * **possibly not available from the iOS store** iPad mini +  * To ensure compatibility,​ visit the [[https://apps.apple.com/​us/​app/ids-ucla/​id1422869521|Apple App Store]] page for the IDS UCLA app and try to install (you'​ll be notified if your device isn't supported)!
-  * ECS Students/​Teachers looking to ease the discover of supported iOS devices can visit **[[http://is.gd/mobilize2013|this page]]** from the mobile device ​to have support automatically detected. ​+
  
 ==== 2 RStudio Web Browser Requirements ==== ==== 2 RStudio Web Browser Requirements ====
-RStudio is an external, open-source project. ​ While they have very liberal browser requirements,​ below is a list of those they recommend on [[http://​support.rstudio.org/​help/​kb/​advanced/​optimizing-your-browser-for-rstudio|this page]] +RStudio is an external, open-source project. ​It supports the following modern browsers. 
-  * Firefox ​3.5 +  * Chrome 
-  * Safari ​4.0 +  * Firefox 
-  * Google Chrome 5.0 +  * Safari ​ 
-  * Internet Explorer (when using the [[http://​www.google.com/​chromeframe|Chrome Frame plugin]])+Not recommended 
 +  * Internet Explorer 
 +  * Microsoft Edge
Print/export